FoxESS H1 5kW and Wave share modbus...

Post Reply
TheDomOfThree
Posts: 6
Joined: Wed Jul 03, 2024 12:36 pm

Hello All,

this is my firs one here so please be patient. I own FoxESS Hybrid inverter H1/5Kw (Master 1.65, Slave 1.02, Manager 1.70). I have decided to connect this thing to my Home Assistant instance so did a bit of a research and decided to go Waveshare route. I have purchased one from PiHut.

So this is where I need your help. I managed to set up the hardware (correctly I believe). I have LAN access to the device via web browser, can PING, can interact with the device. I have blue light on RS484 ACT - which according to the Waveshare manual means RS484 sends data to the Ethernet. I have FoxESS - Modbus integration downloaded to my HA and so on...

Where it all fails is when I am trying to add the modbus in HA. I get that - apparently very common - error that no data has been received.

I tried reconfiguration of the device as per GitHub instructions, tried the factory reset that was suggested in the same post. Did not get any luck. I also tried the direct Ethernet port, however no luck here either - tried both DHCP or static IP, the Ethernet port on the inverter seem to be dead.

I know some users here use the same device, so I would like to ask users to share screen shots of working Waveshare configuration - I am almost sure my configuration is messed up as there is not much in terms of instructions for the RS484 interface on the inverter. The only available option in there is RS485 device ID that is set up to 247 by default.

Any help would be appreciated.
Dave Foster
Posts: 990
Joined: Thu Oct 13, 2022 7:21 pm

If your ACT light is on permanently you have got the A & B wires crossed, it should be flashing with activity otherwise off.

On the inverter you want to make sure that any ethernet capabilities are disabled, and DHCP is off, the only setting for RS485 is slave id which is correct at 247

The settings shown on the wiki page are correct for this device https://github.com/nathanmarlor/foxess ... TH-%28B%29
TheDomOfThree
Posts: 6
Joined: Wed Jul 03, 2024 12:36 pm

Fixed. Got confused with Wavewshare manual entry suggesting that my wiring was correct. It was not. Thank you very much...

Inverter added, however, I can see only 13 entities... None of them is related to actual solar generation... Tried removing and re-adding the device - same result... Any ideas??
Dave Foster
Posts: 990
Joined: Thu Oct 13, 2022 7:21 pm

Can you go to Settings, Devices & Services find 'Foxess-Modbus' and click on the '1 Device' - what sensors do you see there ?, could you take a screen shot of what's available.
TheDomOfThree
Posts: 6
Joined: Wed Jul 03, 2024 12:36 pm

Dave Foster wrote: Thu Jul 04, 2024 3:12 pm Can you go to Settings, Devices & Services find 'Foxess-Modbus' and click on the '1 Device' - what sensors do you see there ?, could you take a screen shot of what's available.
Image
Image

Hope this works.
Last edited by TheDomOfThree on Thu Jul 04, 2024 3:24 pm, edited 1 time in total.
Dave Foster
Posts: 990
Joined: Thu Oct 13, 2022 7:21 pm

TheDomOfThree wrote: Thu Jul 04, 2024 3:19 pm
Dave Foster wrote: Thu Jul 04, 2024 3:12 pm Can you go to Settings, Devices & Services find 'Foxess-Modbus' and click on the '1 Device' - what sensors do you see there ?, could you take a screen shot of what's available.
Image
Image

Hope this works.
It didn't embed them, but I can see they are google drive objects - i'll take a look now.
Dave Foster
Posts: 990
Joined: Thu Oct 13, 2022 7:21 pm

Hmmm, that doesn't look right - can you confirm which version of Home Assistant you are using (Settings, About), particularly 'Core' and also which version of the integration it is (you'll see that by clicking on HACS, Integrations and click on Foxess Modbus)

When you added the device do you select 'TCP' or 'Modbus RTU over TCP'
TheDomOfThree
Posts: 6
Joined: Wed Jul 03, 2024 12:36 pm

HA

Code: Select all

Core 2024.7.0
Supervisor 2024.06.2
Operating System 12.4
Frontend 20240703.0
HACS

Code: Select all

Integration version:	1.34.0
Frontend version:	20240119163101
Repositories:	1390
Downloaded repositories:	5
Foxess modbus version is 1.11.1 as per repo version.

When adding the inverter I did the TCP.
Dave Foster
Posts: 990
Joined: Thu Oct 13, 2022 7:21 pm

Ok, there's the problem there - you are running the latest version of HA Core and unfortunately it has introduced a breaking change to the integration - this should be fixed shortly, but for now it's easy enough to fix it by reverting your HA core back one version.

You can do that by opening a Terminal window and typing

Code: Select all

 ha core update --version 2024.6.4
That will roll you back one version and when it restarts check the how many entities you now have running
TheDomOfThree
Posts: 6
Joined: Wed Jul 03, 2024 12:36 pm

Who are you Almighty Wizard Dave?? I am on 89 entities now :)
Dave Foster
Posts: 990
Joined: Thu Oct 13, 2022 7:21 pm

TheDomOfThree wrote: Thu Jul 04, 2024 3:46 pm Who are you Almighty Wizard Dave?? I am on 89 entities now :)
lol, i've done it a few times and quite close to the integration code ;)

89 entities sounds good, there are more entities available but they are left disabled by default as most people don't use them - EPS voltage etc.. and they will just bloat your database really quickly, if you do want them you can enable them.

I'd recommend you download the charge card which lets you see the normal charge periods https://github.com/nathanmarlor/foxess_ ... eriod_card
TheDomOfThree
Posts: 6
Joined: Wed Jul 03, 2024 12:36 pm

Dave Foster wrote: Thu Jul 04, 2024 3:52 pm I'd recommend you download the charge card which lets you see the normal charge periods https://github.com/nathanmarlor/foxess_ ... eriod_card

Already working on custom dashboard, mainly for mobile devices...


Dave Foster wrote: Thu Jul 04, 2024 3:52 pm
lol, i've done it a few times and quite close to the integration code ;)
Nice one. I will be probably closer o to understanding the code on my retirement... For now not enough days in the week...

As for now thank you very much, have a fantastic day!! Back to setting up my individual devices...
Post Reply